Procore Web Application Errors

Incident Report for Procore Technologies

Resolved

During the incident, users experienced errors on the Procore Web Application. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Mar 25, 2025 - 10:25 PDT

Monitoring

Our engineering team has implemented a solution to remediate the Procore Web Application errors. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Mar 25, 2025 - 09:37 PDT

Investigating

Our engineering teams are continuing to work on restoring normal functionality to the Procore Web Application. We thank you for your patience as we work on this with top priority.

An additional update will be posted as soon as possible.
Posted Mar 25, 2025 - 09:23 PDT

Identified

Our engineering team has identified an issue causing errors seen in the Procore Web Application. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Mar 25, 2025 - 08:51 PDT
This incident affected: Global Services (Login, Web Interface).