Degraded Web App Performance
Incident Report for Procore Technologies
Resolved
Our monitoring shows that web app performance remains stable. We now consider this issue resolved.
Posted 5 months ago. May 14, 2019 - 14:47 PDT
Monitoring
Web app performance has returned to normal, and we're continuing to monitor it closely.
Posted 5 months ago. May 14, 2019 - 14:36 PDT
Investigating
We're investigating degraded performance of the Procore web application. We will provide updates as they become available.
Posted 5 months ago. May 14, 2019 - 14:31 PDT
This incident affected: Web Interface.