Unable to Create Instructions
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted 29 days ago. Aug 21, 2019 - 13:34 PDT
Identified
We have identified the cause of the problem, and are working on a solution.
Posted 29 days ago. Aug 21, 2019 - 13:13 PDT
Investigating
We are currently investigating the inability to create new Instructions. Updates will be posted as they are available.
Posted 29 days ago. Aug 21, 2019 - 11:44 PDT