Procore Errors Pages
Incident Report for Procore Technologies
Resolved
We have confirmed that the issue has been resolved and is no longer impacting customers.
Posted 5 months ago. May 28, 2019 - 16:20 PDT
Monitoring
Our engineering team has identified the issue and users should now be able to login to Procore. We will continue to monitor and provide updates as soon as they become available.
Posted 5 months ago. May 28, 2019 - 15:10 PDT
Investigating
We are investigating an issue that is causing customers to be unable to access the web application. We will provide an update as soon as one is available.
Posted 5 months ago. May 28, 2019 - 12:54 PDT
This incident affected: Web Interface.