Email Delays
Incident Report for Procore Technologies
Resolved
During the incident a vendor outage caused email delays across Procore. We have restored normal functionality and are confident there will be no recurrences. This incident has been resolved.
Posted May 04, 2022 - 08:52 PDT
Monitoring
The vendor outage causing email delays across Procore has been resolved, we are monitoring the situation to ensure a complete resolution.
Posted May 03, 2022 - 18:09 PDT
Identified
Our engineering team has identified the underlying cause of email delays across Procore is due to an outage with Mimecast.
Posted May 03, 2022 - 14:53 PDT
Investigating
Our engineering team is investigating an issue causing email delays across Procore
Posted May 03, 2022 - 12:29 PDT
This incident affected: Global Services (Emails - Outbound).