Issues with Previewing Submittal Responses
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to Submittals and this issue is now resolved.
Posted Apr 02, 2021 - 19:05 PDT
Identified
Our Engineering Team has identified the cause of this issue and are working towards a resolution. Updates will be posted as they become available.
Posted Apr 02, 2021 - 18:43 PDT
Investigating
Our Engineering Team is currently investigating issues with previewing Submittals responses. Updates will be posted as they become available.
Posted Apr 02, 2021 - 17:54 PDT
This incident affected: Project Level Tools (Submittals).