Upstream Timeout Errors
Incident Report for Procore Technologies
Resolved
Our engineering team has confirmed that the "upstream request timeout" errors are no longer ocurring. This incident has been resolved.
Posted Apr 29, 2022 - 07:56 PDT
Monitoring
Our engineering team has implemented their solution and is monitoring the results to ensure a complete resolution. We will continue to post updates as they become available.
Posted Apr 28, 2022 - 23:04 PDT
Identified
Our engineering team has identified the cause of the intermittent "upstream request timeout" errors and is working towards a solution. We will continue to post future updates as they become available.
Posted Apr 28, 2022 - 21:04 PDT
Investigating
Our engineering team is investigating reports of "upstream request timeout" errors occurring on the Procore Web App. We will post additional updates as they become available.
Posted Apr 28, 2022 - 19:45 PDT
This incident affected: Global Services (Web Interface).