Invoicing Micro-frontend is down in beta features
Incident Report for Procore Technologies
Resolved
During the incident, users experienced errors when using the Company level invoice page or the Owner Invoicing beta features. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Mar 15, 2023 - 13:15 PDT
Identified
Our engineering team has identified the cause of some users experiencing errors when using the Company level invoice page or the Owner Invoicing beta features. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Mar 15, 2023 - 12:35 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing errors when using the Company level invoice page or the Owner Invoicing beta features.

Additional updates will be provided as new information becomes available.
Posted Mar 15, 2023 - 11:49 PDT
This incident affected: Company Level Tools (Financials).