Drawing Download Emails Not Being Received
Incident Report for Procore Technologies
Resolved
We now consider this incident to be resolved.
Posted May 13, 2020 - 12:26 PDT
Monitoring
Our Engineering Team has restored normal functionality to Drawing Downloads and is monitoring to ensure this issue is fully resolved.
Posted May 13, 2020 - 09:49 PDT
Investigating
Our R&D team is investigating a problem causing drawing download emails to fail to send. Updates will be provided as they are available.
Posted May 13, 2020 - 07:51 PDT
This incident affected: Project Level Tools (Drawings).