Issue with Accessing T&M CFS Admin Page
Incident Report for Procore Technologies
Resolved
Our engineering team has implemented their solution and restored functionality to the T&M CFS Form admin page. This incident has been resolved.
Posted Apr 28, 2021 - 13:08 PDT
Identified
Our Engineering Team has identified an issue with accessing the T&M CFS Form admin page and is working toward a resolution. Updates will be posted as they become available.
Posted Apr 28, 2021 - 09:36 PDT