Intermittent performance issue with Procore application

Incident Report for Procore Technologies

Resolved

During the incident, users experienced problems navigating Procore applications. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Jun 02, 2023 - 10:14 PDT

Monitoring

Our engineering team has implemented a solution to remediate the performance issues. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Jun 01, 2023 - 13:18 PDT

Investigating

Our engineering team is investigating an issue where users may be experiencing problems navigating Procore applications

Additional updates will be provided as new information becomes available.
Posted Jun 01, 2023 - 12:33 PDT
This incident affected: Global Services (Web Interface).