Platform Degradation | 503 Errors Across Procore

Incident Report for Procore Technologies

Resolved

During the incident, some users may have intermittently experienced 503 errors when navigating the Procore platform. Normal functionality has been restored and this incident has been resolved.
Posted May 14, 2025 - 09:45 PDT

Monitoring

Our engineering team has restored normal functionality to Procore and users should no longer be experiencing errors when navigating the platform. We are monitoring to ensure complete resolution.
Posted May 14, 2025 - 09:37 PDT

Investigating

Our engineering team is investigating an issue causing some users to experience intermittent 503 errors when navigating to certain tools or pages within Procore. We are working to resolve functionality as soon as possible.
Posted May 14, 2025 - 09:32 PDT
This incident affected: Global Services (Web Interface).