Cannot Select Locations
Incident Report for Procore Technologies
Resolved
Our engineering team has restored normal operation to the Location selectors. This incident has been resolved.
Posted Sep 11, 2021 - 13:22 PDT
Investigating
Our engineering team is investigating an issue causing some users to be unable to select Locations in some tools. We will post further updates as they become available.
Posted Sep 11, 2021 - 11:45 PDT
This incident affected: Project Level Tools (Admin).