Owners Platform: "Click Here to Login" Not Working
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to login and this issue is now resolved
Posted Mar 17, 2020 - 10:41 PDT
Investigating
Our Engineering Team is currently investigating issues with the "Click Here to Login" functionality within Procore that directs customers to log into our Owners Platform.
Posted Mar 17, 2020 - 09:12 PDT
This incident affected: Global Services (Login).