The issue affecting data visibility in the ERP Integrations tool has been fully resolved. Users should no longer experience errors when staging records, and Job/Company data is displaying correctly across all integrated connectors. We have implemented measures to ensure continued stability, and all systems are functioning as intended.
Posted Feb 18, 2026 - 09:38 PST
Monitoring
Service has been restored to the ERP Integrations tool. The "failed to stage records" error has cleared, and Job and Company data is once again displaying correctly in the "Ready to Import" and "Archived" tabs. We are monitoring all systems closely to ensure continued stability.
Posted Feb 18, 2026 - 08:26 PST
Update
We are continuing to investigate this issue.
Posted Feb 18, 2026 - 08:04 PST
Investigating
We are currently investigating an issue affecting the ERP Integrations tool where some users may experience intermittent errors. Additionally, Job and Company data may not correctly display within the "Ready to Import" and "Archived" tabs. This issue appears to impact multiple accounting connectors. Our engineering team is actively working to identify the cause and restore full visibility.
Posted Feb 18, 2026 - 07:38 PST
This incident affected: Company ERP Integrations (Acumatica, Sage 100 Contractor, Sage 300, Sage Intacct, Yardi).