Procore Application Degradation

Incident Report for Procore Technologies

Resolved

We have confirmed that the fix implemented by our third-party cloud service provider has successfully restored full functionality to the Procore Platform. This incident is now resolved.
Posted Dec 05, 2025 - 01:40 PST

Monitoring

Our engineering team is monitoring the recovery of the Procore Platform following a fix implemented by our third-party cloud provider. We will continue to closely observe system performance to verify a complete resolution.
Posted Dec 05, 2025 - 01:26 PST

Identified

Our engineering team has identified the cause of the issues impacting the Procore platform. We are awaiting resolution from the public cloud service provider at this time.
Posted Dec 05, 2025 - 01:14 PST

Investigating

Our engineering teams are investigating an issue causing some users to experience errors when navigating the system. We are working to resolve functionality as soon as possible.
Posted Dec 05, 2025 - 01:06 PST
This incident affected: Global Services (Web Interface).