Issues with Login and Page Load
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality and this issue is now resolved.
Posted Mar 10, 2020 - 16:19 PDT
Monitoring
The page loading delays and login failures occurring earlier today have been mitigated, and we are monitoring the situation to ensure the complete resolution of these issues.
Posted Mar 10, 2020 - 11:40 PDT
Update
We are continuing to investigate this issue.
Posted Mar 10, 2020 - 09:44 PDT
Investigating
Our Engineering Team is currently investigating issues with login and loading pages within Procore. Updates will be posted as they become available.
Posted Mar 10, 2020 - 09:33 PDT
This incident affected: Global Services (Emails - Outbound).