Errors on Incidents Edit Page
Incident Report for Procore Technologies
Resolved
This incident has been resolved and users are now able to edit all incident records as intended
Posted 3 months ago. May 07, 2019 - 17:06 PDT
Monitoring
Our engineering team has deployed a fix and users should no longer be experiencing this issue. We are monitoring the situation closely. Thank you for your patience during this interruption.
Posted 3 months ago. May 07, 2019 - 16:22 PDT
Identified
Our engineering team is aware of an issue impacting user ability to reach the incident edit page within the Q&S tool. Note: This only impacts incidents with records (Injury/Near Miss). We are working to address the issue as quickly as possible. Thank you for your patience.
Posted 3 months ago. May 07, 2019 - 14:27 PDT
This incident affected: Web Interface.