Procore Login & Site Wide Issues
Incident Report for Procore Technologies
Resolved
Our Engineering team has mitigated the errors occurring within Procore and this issue is now resolved.
Posted Sep 02, 2020 - 10:23 PDT
Investigating
Our Engineering Team is currently investigating issues with accessing Procore as well as errors occurring within Procore. Updates will be posted as they become available.

Follow Up: Our Engineering Team has determined that the impact of this issue lasted approximately three minutes.
Posted Sep 02, 2020 - 09:27 PDT
This incident affected: Global Services (Login, Web Interface).