Drawing and Submittal Attachment Downloads Failing for A Small Percentage of Users
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Drawing and Submittal tools and this issue is now resolved.
Posted Feb 11, 2021 - 11:02 PST
Monitoring
Our Engineering Team has restored normal functionality to the Drawing and Submittal tools and is monitoring to ensure this issue is fully resolved.
Posted Feb 11, 2021 - 10:13 PST
Update
Our Engineering Team has restored normal functionality to the Drawing and Submittal tools and is monitoring to ensure this issue is fully resolved.
Posted Feb 11, 2021 - 10:12 PST
Investigating
Our engineering team is investigating an issue affecting a small percentage of our users that is preventing Drawing and Submittal Attachment downloads. We will post updates as they become available.
Posted Feb 11, 2021 - 09:45 PST
This incident affected: Project Level Tools (Drawings, Submittals).