During the incident, users experienced some stale data in 360 Reporting and Procore Analytics 2.0. Our engineering team has restored normal functionality, this incident has been resolved.
Posted May 21, 2025 - 15:17 PDT
Monitoring
Our engineering team has implemented a solution to remediate the stale data in 360 Reporting and Procore Analytics 2.0. We are monitoring the situation to ensure a complete resolution.
Additional updates will be provided as new information becomes available.
Posted May 21, 2025 - 14:44 PDT
Identified
Our engineering team has identified the cause of the stale data in 360 Reporting and Procore Analytics 2.0. We are actively working towards a solution.
Additional updates will be provided as new information becomes available.
Posted May 21, 2025 - 13:38 PDT
Investigating
Our engineering team is investigating some stale data in 360 Reporting and Procore Analytics 2.0. We are actively working towards a solution.
Additional updates will be provided as new information becomes available.
Posted May 21, 2025 - 13:30 PDT
This incident affected: Company Level Tools (360 Reporting, Procore Analytics 2.0).