Issues with Creating Action Plans from Templates
Incident Report for Procore Technologies
Resolved
This issue is now resolved.
Posted Nov 09, 2020 - 21:50 PST
Investigating
Our Engineering Team is investigating issues with creating Action Plans from Templates. Updates will be posted as they become available.
Posted Nov 09, 2020 - 20:08 PST