Slow iOS Load Times
Incident Report for Procore Technologies
Resolved
Procore for iOS v2022.0530.2 is now available in the AppStore. The v2022.0530.2 release corrects the user interface performance issue first introduced in the v2022.0523 app release.
Posted Jun 09, 2022 - 08:32 PDT
Update
The mobile engineering team has found and corrected an issue that caused user interface responsiveness issues in our iOS mobile app. We are working to release version 2022.0530.2 of the iOS app as soon as possible. We will post an update again once v2022.0530.2 is available in the AppStore.
Posted Jun 08, 2022 - 15:33 PDT
Identified
Our engineering team is investigating an issue causing slow load times when accessing our iOS application. We will post additional updates as they become available.
Posted Jun 08, 2022 - 13:53 PDT
This incident affected: Mobile Platforms (iOS Procore Application) and Project Level Tools (Drawings).