Security filters incorrectly flagging legitimate Procore emails

Incident Report for Procore Technologies

Update

We are continuing to monitor for any further issues.
Posted Oct 14, 2025 - 10:20 PDT

Monitoring

We are aware of an issue where some customers are receiving phishing warnings related to Procore email links. Our investigation of the reported emails indicates that the phishing warnings were caused by a commonly used email filtering system misclassifying the emails. The emails reviewed were not malicious in nature.

We are actively working with the provider to resolve this misclassification and restore normal email deliverability. We will provide updates as more information becomes available.
Posted Oct 14, 2025 - 10:07 PDT

Investigating

We're aware that some clients are experiencing email delivery issues caused by security filters incorrectly flagging legitimate Procore emails. Our team is actively engaged with the third-party provider to resolve the issue.
Posted Oct 14, 2025 - 08:21 PDT
This incident affects: Global Services (Emails - Inbound, Emails - Outbound).