Attachments on Owner Payment Applications are not Saving
Incident Report for Procore Technologies
Resolved
Our R&D team has restored functionality to Owner Payment Application Attachments. We now consider this incident to be resolved.
Posted May 26, 2020 - 11:54 PDT
Identified
Our R&D team has identified the cause of the problem and is working on implementing a solution.
Posted May 26, 2020 - 08:12 PDT
Investigating
Our R&D team is investigating a problem causing attachments on Owner Payment Applications to fail to save. Further updates will be posted as they become available.
Posted May 26, 2020 - 07:47 PDT
This incident affected: Project Level Tools (Invoicing).