Platform Degradation | Intermittent 500 Errors

Incident Report for Procore Technologies

Resolved

During the incident, some users may have experienced intermittent 500 errors while navigating the Procore platform. Our engineering team has restored normal functionality and this incident has been resolved.
Posted Mar 04, 2025 - 15:16 PST

Monitoring

Our engineering team has implemented a fix and restored normal functionality to Procore. Users should no longer be experiencing 500 errors when navigating the platform. We are monitoring to ensure complete resolution.
Posted Mar 04, 2025 - 14:53 PST

Update

Our engineering team is continuing to investigate an issue where some users may be intermittently experiencing 500 errors when navigating the Procore platform. Clearing browser cache may temporarily allow users to navigate past the error page as a workaround.
Posted Mar 04, 2025 - 13:22 PST

Investigating

Our engineering team is investigating an issue where some users may be intermittently experiencing 500 errors when navigating the Procore platform. We are working to restore normal functionality as soon as possible.
Posted Mar 04, 2025 - 13:08 PST
This incident affected: Global Services (Web Interface).