Long Wait Times for Support Live Chat
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 12:31 PST
Identified
We are currently experiencing longer than normal wait times for our Live Chat. We are doing everything we can to mitigate this. We will post updates as they are available.
Posted Nov 15, 2019 - 07:58 PST
This incident affected: Supporting Platforms (Support Center).