New users unable to sign up and submit intake form
Incident Report for Procore Technologies
Resolved
Engineering teams have resolve this incident. Functionality has been restored.
Posted Nov 14, 2022 - 12:55 PST
Investigating
Our engineering team is investigating an issue where new users are unable to sign up and preventing the intake form from being submitted.

Additional updates will be provided as new information becomes available.
Posted Nov 14, 2022 - 10:03 PST
This incident affected: Procore Construction Network (Web Interface).