Intermittent Application Latency and Errors

Incident Report for Procore Technologies

Resolved

During the incident, a subset of users experienced intermittent error pages and loading disruptions when attempting to access or navigate the platform. These performance fluctuations stemmed from an issue with a third-party cloud service provider. Our engineering team has verified that all network error signals have completely subsided, normal functionality has been fully restored, and this incident has been resolved.
Posted Jun 22, 2026 - 17:39 PDT

Monitoring

Our engineering team is actively monitoring an issue with a third-party cloud service provider that is resulting in intermittent errors for a portion of customers accessing and navigating the Procore platform. While we are tracking signs of stabilization, performance may remain intermittent as the provider works toward a resolution.

If you encounter an error page or slow loading times, please refresh your browser or retry your action. 

Additional updates will be provided as new information becomes available.
Posted Jun 22, 2026 - 07:46 PDT

Identified

Our engineering team has identified the cause for some users to experience intermittent errors and long load times when navigating the Procore platform. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Jun 22, 2026 - 07:18 PDT

Investigating

Our engineering team is investigating an issue causing some users to intermittently errors 5XX errors or long load times across the platform. We are actively working towards a solution.

Additional updates will be provided as new information becomes available.
Posted Jun 22, 2026 - 07:00 PDT
This incident affected: Global Services (Web Interface).