Issue with Equipment Tool Attachments
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to the Equipment Tool. This incident has been resolved.
Posted Mar 04, 2020 - 20:54 PST
Investigating
Our Engineering Team is currently investigating issues with opening attachments within the Equipment Tool. Updates will be posted as they become available.
Posted Mar 04, 2020 - 14:37 PST