Load Time Issues
Incident Report for Procore Technologies
Resolved
Normal functionality to drawings and load times have been restored.
Posted Oct 20, 2019 - 21:52 PDT
Monitoring
Normal functionality to drawings and load times have been restored. We are currently monitoring to ensure the issue is fully resolved.
Posted Oct 20, 2019 - 19:53 PDT
Update
We have become aware of issues regarding load time as well as issues with downloading drawings. We are currently investigating further. Updates will be posted as they become available
Posted Oct 20, 2019 - 17:01 PDT
Investigating
We have become aware of issues regarding load time and are currently investigating further. Updates will be posted as they become available
Posted Oct 20, 2019 - 15:31 PDT
This incident affected: Global Services (Web Interface) and Project Level Tools (Drawings).