Issue logging into Procore Owner Platform
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 07:04 PDT
Identified
We have identified the issue and are working on a fix. The impact has been minimized until the full solution has been implemented.
Posted Mar 11, 2020 - 06:09 PDT
Investigating
Our Engineering team is currently investigating an issue preventing customers from logging into our Owner Platform.
Posted Mar 09, 2020 - 16:02 PDT
This incident affected: Procore Owner Platform.