Slow Load Times throughout Procore
Incident Report for Procore Technologies
Resolved
Our engineers have restored normal function and load times. This incident is Resolved.
Posted Jun 27, 2019 - 09:00 PDT
Monitoring
We are no longer experiencing slow page load times throughout Procore.
Posted Jun 27, 2019 - 08:07 PDT
Identified
Our engineering team has identified the issue and is working on a resolution.
Posted Jun 27, 2019 - 07:56 PDT
Investigating
We are aware of slow page load times throughout Procore and our engineering team is actively investigating this issue.
Posted Jun 27, 2019 - 07:41 PDT
This incident affected: Global Services (Web Interface).