Delayed Processing
Incident Report for Procore Technologies
Resolved
During the incident, users experienced delays with processing of some functionalities. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Dec 08, 2023 - 08:53 PST
Monitoring
Our engineering team has implemented an updated solution to remediate delays in Procore processing some functions. We are continuing to monitor the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Dec 08, 2023 - 08:07 PST
Investigating
During the monitoring period, our engineering team observed indicators that the delays may reoccur. We are continuing to investigate this issue.

Additional updates will be provided as new information becomes available.
Posted Dec 08, 2023 - 05:49 PST
Monitoring
Our engineering team has implemented a solution to remediate delayed processing of some functions. We are monitoring the situation to ensure a complete resolution.

Additional updates will be provided as new information becomes available.
Posted Dec 08, 2023 - 05:34 PST
Investigating
Our engineering team is investigating a situation where users may be experiencing slower than normal processing of functions.

Additional updates will be provided as new information becomes available.
Posted Dec 08, 2023 - 05:07 PST
This incident affected: Global Services (Procore Analytics, Web Interface).