360 Reporting Intermittently Unavailable

Incident Report for Procore Technologies

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 18:02 PST

Monitoring

Engineers have identified and resolved the issue impacting a subset of users for our 360 Reporting tool. Report functionality is working as expected. We will continue to monitor the incident to ensure complete resolution.
Posted Feb 18, 2026 - 17:46 PST

Identified

Engineers are aware of an issue impacting some users in our 360 Reporting tool. Users may be experiencing intermittent issues generating reporting at this time. We are working to restore normal functionality and will update as new information becomes available.
Posted Feb 18, 2026 - 17:35 PST
This incident affected: Company Level Tools (360 Reporting).