Issues with Loading the Bidding Tool
Incident Report for Procore Technologies
Resolved
Our Engineering team has restored normal visibility to the Bidding Tool. This incident has been resolved.
Posted Feb 19, 2021 - 12:42 PST
Investigating
Our Engineering Team is currently investigating issues with loading pages within the Bidding Tool. Updates will be posted as they become available.
Posted Feb 19, 2021 - 10:49 PST
This incident affected: Project Level Tools (Bidding).