Third Party Document Signature Issues
Incident Report for Procore Technologies
Resolved
Confirmation has been received from our Third-Party documents provider that the issues within their environment have been resolved. Full functionality of Documents, Invoicing, Commitments, Change Orders, and Prime Contracts are working as expected.
Posted May 24, 2022 - 16:22 PDT
Monitoring
We are monitoring an issue with our third party documents provider. This will be impacting functionality of Documents, Invoicing, Commitments, Change Orders, and Prime Contracts. At this time, we are pending vendor resolution and will provide updates as they come available.
Posted May 24, 2022 - 13:29 PDT
This incident affected: Project Level Tools (Change Orders, Commitments, Documents, Invoicing, Prime Contract).