Timesheet Functionality
Incident Report for Procore Technologies
Resolved
We have resolved all the errors being seen on Timesheets and the system is now functioning correctly.
Posted 3 months ago. Jul 25, 2019 - 14:09 PDT
Identified
Our engineering team has identified the cause of the errors on Timesheets, and are working on the solution.
Posted 3 months ago. Jul 25, 2019 - 13:14 PDT
Investigating
Our Engineering team is investigating the cause of limited Timesheets functionality. We will post updates as they become available.
Posted 3 months ago. Jul 25, 2019 - 13:01 PDT