Owner Invoice Detail Page Not Loading
Incident Report for Procore Technologies
Resolved
Normal page loading of Owner Invoices has been restored. This issue is now resolved.
Posted Oct 14, 2019 - 11:38 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 14, 2019 - 11:37 PDT
Monitoring
Normal page loading of Owner Invoices has been restored. We are continuing to monitor to ensure this issue is fully resolved.
Posted Oct 14, 2019 - 11:28 PDT
Investigating
Our Engineering team is investigating an issue where customers are unable to access the Details page for Owner Invoices.
Posted Oct 14, 2019 - 09:59 PDT
This incident affected: Project Level Tools (Prime Contract).