Budget Snapshots on app.procore.com
Incident Report for Procore Technologies
Resolved
Our Engineering Team has restored normal functionality to Budget Snapshots and this issue is now resolved.
Posted Dec 02, 2020 - 17:31 PST
Identified
Our Engineering team has identified the issue with Budget Snapshots and is working to restore normal functionality.
Posted Dec 02, 2020 - 14:14 PST
Investigating
Our Engineering team is investigating an issue preventing customers from taking Budget Snapshots on app.procore.com
Posted Dec 02, 2020 - 13:53 PST
This incident affected: Project Level Tools (Budgeting).