Intermittent Errors for Subset of Users
Incident Report for Procore Technologies
Resolved
This incident has been resolved. Application functionality continues to work as expected.
Posted Mar 07, 2024 - 15:05 PST
Monitoring
Our engineers have identified and mitigated an issue impacting a subset of users who may have experienced errors while navigating throughout the Procore Application. Teams will continue to monitor the situation and updates will be provided as additional information becomes available.
Posted Mar 07, 2024 - 14:15 PST