Problems with Calls to Procore Support
Incident Report for Procore Technologies
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 11:08 PDT
Investigating
We are investigating problems regarding calling into Procore's Phone Support. Contact via email or live chat is still available.
Posted Mar 23, 2020 - 07:42 PDT
This incident affected: Support Center.