Users unable to load several tools, including Drawings, Specs, Meetings, Submittals, Documents, and Emails
Incident Report for Procore Technologies
Resolved
During the incident, users experienced loading Drawings, Specs, Meetings, Submittals, Documents, and Emails among other tools Our engineering team has restored normal functionality, this incident has been resolved.
Posted Oct 24, 2022 - 17:45 PDT
Investigating
Our engineering team is investigating an issue where users may be experiencing problems loading Drawings, Specs, Meetings, Submittals, Documents, and Emails among other tools

Additional updates will be provided as new information becomes available.
Posted Oct 24, 2022 - 16:13 PDT
This incident affected: Project Level Tools (Drawings, Emails Tool, Meetings, Specifications, Submittals).