Issue with the Total Completed and Stored changes for Sub Invoicing
Incident Report for Procore Technologies
Resolved
During the incident, users experienced an issue with the Total Completed and Stored changes for Sub Invoicing. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Jan 17, 2023 - 09:43 PST
Investigating
Our engineering team is investigating an issue with the Total Completed and Stored changes for Sub Invoicing.

Additional updates will be provided as new information becomes available.
Posted Jan 17, 2023 - 08:21 PST
This incident affected: Project Level Tools (Invoicing).