Intermittent Delays in Webhook Deliveries & ERP Integration Exports
Incident Report for Procore Technologies
Resolved
Our Engineering teams have worked throughout the weekend to restore and validate Webhook deliveries and ERP Integration exports. All services are working as expected, and this incident has been resolved.
Posted May 16, 2022 - 09:54 PDT
Update
Engineering teams have identified the root cause of the delays and will be implementing a temporary fix during a scheduled maintenance event the evening of 5/13. Until this fix is implemented, a subset of clients may still be experiencing delays in Webhook deliveries & ERP Integration exports.

Teams are confident they have identified the permanent fix for this issue and will be implementing that during a second maintenance window on 5/20.

We understand this disruption is impactful to our customers and appreciate your patience as we work towards full remediation.
Posted May 11, 2022 - 18:12 PDT
Identified
Our Engineering teams have identified the issue and are working towards resolution with the utmost priority. During this time, a subset of customers may still be experiencing delays in Webhook deliveries and ERP integration exports averaging around 5 minutes. A small fraction of the impacted customers may be seeing delays up to one hour.

Additional updates will be provided as new information becomes available.
Posted May 11, 2022 - 14:59 PDT
Update
Our Engineering team continues to investigate this issue with the utmost priority. A subset of clients may still be experiencing an average delay of 5 minutes in Webhook Deliveries & ERP integration Exports. A small fraction of customers may still be experiencing a delay of up to one hour.

Additional updates will be provided as new information becomes available.
Posted May 11, 2022 - 14:33 PDT
Investigating
A subset of customers may be experiencing an average delay of 5 minutes in Webhook deliveries and ERP integration exports. A small fraction of the impacted customers are seeing delays of up to an hour. Teams are working to resolve this disruption with the utmost priority.

Additional updates will be provided in 60 minutes, or as new information becomes available.
Posted May 11, 2022 - 12:54 PDT
This incident affected: Sandbox Environments and API (Webhooks).