Intermittent Login Issues

Incident Report for Procore Technologies

Resolved

Our engineering team has remediated the issue responsible for a high volume of unexpected "Welcome" emails being sent to a subset of our users. This incident has been resolved.
Posted Mar 05, 2026 - 14:09 PST

Monitoring

Procore has identified an internal source responsible for a high volume of unexpected "Welcome" emails being sent to a subset of our users. While this caused a temporary spike in login traffic, we have verified the source and are monitoring the situation as system performance returns to normal levels.
Posted Mar 05, 2026 - 13:50 PST

Investigating

Engineers are currently investigating an intermittent issue with our Login services which may have inadvertantly logged out some users. Login functionality is working as expected, and any users who were logged out can log back in without issue. Additionally, a subset of users may be receiving 'Welcome' emails for historical companies. Teams are engaged and working to remediate the issue.
Posted Mar 05, 2026 - 12:55 PST
This incident affected: Global Services (Login).