Some Assets Unavailable in Procore

Incident Report for Procore Technologies

Resolved

During the incident, some users may have experienced issues loading web pages across the Procore platform. Our engineering team has restored normal functionality and this incident has been resolved.
Posted Sep 03, 2025 - 13:03 PDT

Monitoring

A fix has been implemented for the missing assets and we are monitoring to confirm a full resolution.
Posted Sep 03, 2025 - 11:45 PDT

Investigating

We are currently working to resolve an issue with some items not loading on web pages across Procore.
Posted Sep 03, 2025 - 11:36 PDT
This incident affected: Global Services (Web Interface).