Increased Latency

Incident Report for Procore Technologies

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 13:08 PDT

Monitoring

We have confirmed that system performance is back to normal and we will continue to monitor as the third party vendor provides updates.
Posted Aug 21, 2025 - 12:58 PDT

Identified

We have identified an issue with a third party vendor that has caused an increase in latency across the Procore application. We are working with the vendor to restore normal functionality and will provide updates as available.
Posted Aug 21, 2025 - 12:01 PDT

Investigating

We have identified an issue with a third party vendor that has caused an increase in latency across the Procore application. We are working with the vendor to restore normal functionality and will provide updates as available.
Posted Aug 21, 2025 - 11:38 PDT
This incident affected: Global Services (Web Interface).