Inbound Support Phone Line
Incident Report for Procore Technologies
Resolved
We have resolved this issue and are no longer experiencing technical difficulties with our inbound support phone lines.
Posted 4 months ago. Jun 18, 2019 - 11:33 PDT
Investigating
We are currently experiencing technical difficulties with our inbound support phone lines. For immediate assistance, please email us at support@procore.com or chat in via the question mark in the top right of Procore.
Posted 4 months ago. Jun 18, 2019 - 11:01 PDT
This incident affected: Support Center.