Submittal Attachment Issue
Incident Report for Procore Technologies
Resolved
During the incident, users experienced an issue with the visibility of attachments in newly created submittals. Our engineering team has restored normal functionality, this incident has been resolved.
Posted Dec 15, 2023 - 15:41 PST
Identified
Engineering teams are implementing a fix for the issue impacting visibility of attachments in newly created submittals.

Additional updates will be provided as new information becomes available.
Posted Dec 15, 2023 - 13:24 PST
Investigating
Engineers are investigating an issue that may be impacting the visibility of attachments in newly created submittals.

Customers creating a new submittal with an attachment may not see the attachment when the submittal is created. The attachment will appear on the form only after updating the submittal.

Updates will be provided as new information becomes available.
Posted Dec 15, 2023 - 12:06 PST
This incident affected: Project Level Tools (Submittals).